If you had an account on forum.suprbay.org with at least one post, you do not need to re-register. Your account is still active and your Suprbay username and password will work.

VPN
#11
If you haven't spent much time around the darker corners of the web like pirate download sites, one skill you will need to develop is how to navigate around the ads they present.

They are a special kind of cancer you don't find on the rest of the web. Whichever ad networks TPB chooses to go with aren't the very bottom of the barrel, but they are close.

They bottom line is that the usage of a VPN, or lack thereof, has no bearing on what ads appear or how to make them go away.
Reply
#12
(Jan 08, 2020, 12:05 pm)verna2197 Wrote: I have and use a VPN but your site keeps telling me I do not. I use IPVanish. Can you please tell me how to fix the site from telling me this?

I got around this issue by adding the info hash. In your application, chose add by url and type magnet:?xt=urn:btih:'info hash of torrent'.

Hope that helps.
Reply
#13
I can't get past this ad....anyone got any hints? I've been using the bay for years and years, never seen an ad as persistent as this. I've tried 5 different browsers. I would also like a way to let the TPB overlords know how badly this ad is screwing everything up.
Reply
#14
Which adblocker are you using? This is a screenshot of recent torrents using firefox browser:

https://i.imgur.com/J2CPIU6.jpg

I use adblockplus and don't have to disable it to view the site. If you're not using ABP, give it a try.

Btw, there is only one tpb overlord: the tpb admin.
Reply
#15
I also use ABP and the list of torrents looks the same for me. But when I click on a download link or magnet link I get this shite:

[Image: lInc3SP.jpg]


I can close it but it comes back every time I try to download something. I tried a script blocker but that disabled the links as well as the ad. It feels more like a virus than an ad - it's so annoying. I looked in Chrome's Task Manager but I couldn't see a way to end it.

I don't use a VPN by the way. I don't want one. I always use the bay via this: https://avoidcensorship.org/ Maybe I need a different mirror? Other people are reporting this problem: https://www.reddit.com/r/thepiratebay/co...55r6/okay/

Problem solved! I just went here: https://thepirate-bay.org/ I hope whoever runs https://avoidcensorship.org/ burns in hell.
Reply
#16
We don't support the usage of proxies. The only sites we support are in the footer of this page.
Reply
#17
Lesson learned. Thank you for your help.
Reply
#18
adblockers don't solve it. At least any ad blocking extension on chrome does. It redirects to another page when I press the "get this torrent" button. Has anyone actually been able to solve this problem?
Edit: I mean while still using proxies. I tried using the thepiratebay.org but it seems I am having another issues there too (related to javascript loading it seems)
Reply
#19
Proxies have nothing to do with us, and some of them are really, really shite and been known to show fakers that have been banned from the real TPB weeks previously, not to mention some are absolutely riddled with dodgy ads and VPN notices.

To use the real TPB, just 'temporary enable all' if you're got a JS blocker so that you can browse the site, or use the onion address. If you do use a proxy, please find a better one that is free of ads. If you use adblock plus, you don't have to disable it to use the real TPB.
Reply
#20
(Jun 22, 2020, 04:53 am)Spud17 Wrote: Proxies have nothing to do with us, and some of them are really, really shite and been known to show fakers that have been banned from the real TPB weeks previously, not to mention some are absolutely riddled with dodgy ads and VPN notices.

To use the real TPB, just 'temporary enable all' if you're got a JS blocker so that you can browse the site, or use the onion address. If you do use a proxy, please find a better one that is free of ads. If you use adblock plus, you don't have to disable it to use the real TPB.
Thanks very much for your response I tried again the  TPB.org but this time I remembered to try it without the Windscribe VPN and it seems the problem went away. That means it had some kind of JS blocker? Basically trying to solve a problem I created another problem  Undecided Undecided . Oh well it is solved now...
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  VPN or Tor or both? gigettina 4 9,736 Dec 01, 2018, 08:49 am
Last Post: RodneyYouPlonker
  SuprBay: 403 error to suprbay when VPN turned on azboxfta 5 10,560 Jul 30, 2014, 03:22 am
Last Post: eshborn
  Pirate Bay: Privitize VPN buckaroo2409 10 18,719 Dec 15, 2013, 19:26 pm
Last Post: buckaroo2409



Users browsing this thread: 1 Guest(s)