Help Needed: Can't play DirectPlay games in Windows 7
#1
After setting Parental Controls via my router to limit Internet access to my Windows 7 machine, all my Windows 7 Directplay games can't play network (LAN) games anymore.

I tried taking out the Parental Controls, but it still doesn't work.

How do I proceed? Windows 7 is up-to-date with the latest ESU patches (believe me, they still update Windows 7 even though they it's end-of-life, and will continue to do so until October of this year)?

EDIT: This was a message I sent to TP-Link after I typed this message. I'm including it because it was more detailed than the one above.

RobertX Wrote:I am using two computers to play a two player network game: one is a Windows 11 Pro machine and one is a Windows 7 Ultimate machine. The Windows 7 machine is locked out of Internet access by means of Parental Control.

The reason I blocked my Windows 7 computer out of Internet access was that I am under the impression that it will be vulnerable to hackers. At the same time, I still want to use my Windows 7 computer for basic functions, offline network storage, and IPX/SPX/TCP/UDP network gaming, while being protected from outside threats. Perhaps that is a misconception, but for my purpose, I would like to still usage until it breaks down permanently and yet protect it from whatever I can protect from it. I would opt to use Windows 10, but I have no drivers supporting that operating system.

All was well until I turned off the Windows 7 computer and turned it back on as a test. When I tested games Command and Conquer Generals Zero Hour and the legacy versions of Warcraft III: The Frozen Throne (not the new Reforged version), I can see no games being created when there were. Thinking it was Parental Controls that created the problem, I disabled it, but the problem persisted nonetheless, especially when I reinstated Internet access to the Windows 7 computer, but there were no resolutions.

I asked around the Internet, but I have yet to have an answer. I asked OpenAI, but the bot would just offer generic solutions that do not pertain to the problem. I tried looking for DirectPlay, but while Windows 11 has it, Windows 7 had no such option.

One thing that might help: I enabled and disabled Parental Control by checking and unchecking the topmost checkbox of the page respectively, I did not go through with the Clear Schedule buttons located below. Should I do that?
Anything that might help me is welcome.

Thank you.
EDIT: I should also add that access to the network from all three computers (including the Windows 7 one) is still possible.

EDIT: I should also add this too:
The Header Information Wrote:Tags: #Network Connectivity #Parental Control #Installation #gaming
Model: TL-WR841N
Hardware Version: V14
Firmware Version: 0.9.1 4.19 v0348.0 Build 220816 Rel.43928n

And finally, the link: https://community.tp-link.com/en/home/fo...918?page=1
Reply
#2
Hi, Moeng.

This is embarrassing, but how?

EDIT: Before you answer, I think I should point out that before I put Parental Control on Windows 7, it was working all right. I didn't need to lower the firewall on either one, or at least, I disabled the official firewall of my Windows 7 computer and installed AVG Antivirus which included a firewall and operated from there.

But all in all, it was all right before I put on Parental Control on the Windows 7 compute's MAC address.

EDIT: It wasn't like that on the Linux Mint computer when it ran the same game under and when I tested it under the same conditions (i.e. Parental control, shutdown and boot-up).
Reply
#3
LAN.

Apologies, I thought the term DirectPlay might have been self-explanatory, but I see I was wrong.

I'll do what you ask me of.

EDIT: Well, for the Windows 7 computer, I already turned off the firewall, and not only, I also disabled it from services. I just uninstalled the antivirus and it's still acting a little stupid.

EDIT: I think to be specific, it's TCP/IP LAN. I know that's what I tested with Starcraft. The protocol that my version of Starcraft uses is called UDP/IP. I also believe that's what Command and Conquer Generals uses as well. Does that have any bearing with the router?
Reply
#4
OK, I seem to be angering you. If you don't want to help me, you can opt out. I apologise for that.

I don't have anything configured as of now. No parental controls, no DHCP, no UAC, all the necessary protocols, all manual network settings (so, manual IP, manual DNS server, no VPNs enabled, etc. As of now, on the Windows 7 computer.

I'll take my business elsewhere.
Reply
#5
Yes, it is cable.
Reply
#6
Well, yeah, I can ping either machine.

I can access the Windows shares.

I'll tell you what, I'll do further experimentation on my own. After all, that's how you learn.

Thank you for offering, and welcome to SuprBay!

What the hell?

Why were Mooeng's posts deleted?
Reply
#7
OK, I think I have gotten to the bottom of this.

Every time I want to play a LAN game, I just disable the Virtualbox Host Only Adaptor because it was causing errors.

Now, the mess started when I took the Windows 7 PC offline by not specifying the gateway address and the DNS server address. This is the correct way to do so because without the specifying the gateway, the computer would have no way to communicate with anything outside its local network, or so I think. This was the intended effect. The computer literally doesn't have access to websites or Discord; it's rendered offline. Thanks to Moe on that one.

Thanks partly to Mooeng for schooling me and offering to help, though his attitude problem leaves much to be desired.

Now, I'm going to eat.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Where can i get old working DOS games? ice_world.009 2 551 Jul 13, 2024, 17:57 pm
Last Post: ice_world.009
  Where to get old games like Demigod (2009) feebs69 1 552 Jul 13, 2024, 08:29 am
Last Post: samui
  Updating Cracked Games yusufarslan05 2 2,360 Feb 16, 2024, 10:35 am
Last Post: yusufarslan05
  The new Ubisoft+ and getting gamers comfortable with not owning their games!? lustrous 7 3,520 Feb 04, 2024, 16:36 pm
Last Post: lustrous
  Your favorite racing games theSEMAR 39 102,252 Nov 07, 2023, 18:21 pm
Last Post: lustrous



Users browsing this thread: 1 Guest(s)